phpMany website operators and shop owners have recently received an important email regarding the PHP update - which shouldn’t be disregarded, but considered important, not to make a mistake that can lead to the loss of your website and consequently revenue losses.

Although the email informed that old PHP versions will not be supported anymore by the end of this year - and the new versions automatically come into force – the consequences haven’t been explained, like what could happen if the current system or CMS is not compatible with the latest PHP version.

Christoph Gärtner, Managing Director of the advertising agency Pixelwerker and expert for SEM and content marketing provides us with a brief summary of what can happen to online shop and website operators at the end of the year, when PHP 5.6 and 7.0 will be shut down.

The scripting language PHP is used by most common shop systems and content management systems - in fact 83% of all websites worldwide use PHP. But the support for PHP 5.6 ends on December 31 and for PHP 7.0 already on December 3, 2018.The problem is that currently still more than 62% use a PHP 5 version, which demands urgent actions.

PHP regularly releases new, better versions that can, among other things, answer more queries per second than previous versions and closes security holes. For each release, PHP provides full support for approximately two years. In the third year the support is limited and serves only to close security gaps. With the shutdown, website operators who still use an old PHP version must now decide on a new one.

How to update your PHP version

Experts recommend updating directly to PHP 7.2, as support for PHP 9.1 will be completed by December 2019, especially since PHP 7.2 has additional improvements compared to the previous PHP versions: It can, for example, perform almost three times as many requests per second as PHP 5.

The conversion to PHP 7.1 or 7.2 usually requires just a click in the customer portal of your provider. Nevertheless, you should pay attention to a few things before acting. Find out first if the current version of your CMS or shop system is compatible with the desired PHP version. If you update PHP, and at the same time use an unsupported version of your CMS, this can lead to failure of your website. So, make sure that all extensions and plug-ins remain functional with the conversion. If this is not the case, update them too. It may happen that for some less used plug-ins no newer version is available, which means you need to find an alternative for the plugin. Before doing so, make sure to have backed up your website, database and all files. After the transition, check if your website is still functional. If there are any difficulties in adjusting your website, contact an expert to avoid not only making mistakes, but wasting unnecessary time and expense.

Content Management Systems (CMS) put to test

WordPress - compatible from WordPress 4.9 onwards

To make sure your WordPress site stays accessible, you need WordPress 4.9. Many WordPress users can now breathe a sigh of relief, as already 66.2% use this version. But if you still need to update your WordPress, you should first check your extensions and plug-ins or use the PHP Compatibility Checker, that can verify all plug-ins and themes.

Typo3 - compatible from Typo3 7 onwards
Most Typo3 users can sit back and relax because the CMS was already compatible with PHP 7.x from version 7 on. However, from Typo3 9.0 onwards only all versions as of PHP 7.2 are supported and switching to a newer Typo3 version is not that easy, but experts can of course always help.

Contao - compatible from Contao 3.5.5 onwards
PHP 7.1 and 7.2 are supported as of version 3.5.5. But Contao 4.5.4 is already available, which of course brings some improvements. Anyway, when updating, be sure to update all plug-ins and extensions to keep your site functional after installation.

Joomla! - compatible from Joomla! 4 onwards
Many Joomla! users are affected by the PHP update: While Joomla!3.4 was still compatible with PHP 7.0, Joomla! 4 can only be used with higher versions, forcing many to update their website.

Drupal - compatible with PHP 7.2 as of Drupal 8.5.0
With Drupal we advise as well to switch directly to PHP 7.2, meaning you need Drupal Version 8.5.0. But there is no hurry to do so, since the support of Drupal 5 and 7.0 will end only in June 2019.

Shop systems put to test

Shopware - compatible from Shopware 5.3.5 onwards
Shopware 5.3.5 is compatible with PHP 7.1 and 7.2. It should be noted, however, that no ionCube encrypted plug-ins can be used. Experts recommend updating to Showware 5.5, as this release uses open-source plug-ins and is therefore 100% compatible with PHP 7.x.

Magento - Magento 1 is compatible with the new PHP 7.2 Support Patch and Magnet 2.3 supports so far PHP 7.1. On September 14, 2018 Magento released the new PHP 7.2 support patch for Magento 1, which allows Magento 1 users to conveniently upgrade to PHP 7.1 or higher. If you use Magento 2.3, you should first switch to PHP 7.1.

Oxide - compatible from Oxide 6.1.0 onwards
Oxid supports PHP 7.1 or higher from version 6.1.0. Since the merchandise management system was originally developed for PHP 5, some users may be pleased now that the conversion to PHP 7.1 or higher means only one click on their provider portal.

Contenido- compatible from Contenido 4.9 onwards
Starting from version 4.9, Contenido supports all PHP versions from 5.3.0 onwards, which means the transition to PHP 7.1 or higher should be uncomplicated.

OpenCart - compatible from OpenCart onwards
PHP 7.1 and 7.2 are supported from OpenCart version onwards. But because OpenCart was originally designed for PHP 5.6, it can still come to some errors. For this reason, you should first check the functionality of the shop during the update on a test page.

Modified eCommerce Shopsoftware- compatible as of version
Version of the Modified eCommerce Shopsoftware is compatible with PHP 5.6 through PHP 7.1.For now, users can not switch to PHP 7.2.

xt: Commerce - compatible from xt: Commerxe 5.1 onwards
Even for many xt: Commerce users, the transition to PHP 7.1 and PHP 7.2 is straightforward, as they are already supported as of version 5.1. If you use an older xt: Commerce version, you should update your online shop soon, before it comes to failures in the course of the PHP update.

Spryker - Spryker has been compatible with PHP 7.1 or later since the end of October
By the end of October, Spryker has already terminated support for the older versions of PHP. In this context, the new Spryker 2.3 update came out, which should now be installed at all online stores.

With the end of support for PHP 5.5 and 7.0 website and show operators are under pressure not to risk losing revenue and time. Hence, find out asap if you are affected by the update and don’t forget to check the compatibility with your current CMS or shop system.

By Daniela La Marca